eSIM Platform Vendor Service Degradation

Incident Report for Telna Status

Resolved

Hello,

This is to update you regarding the following incident:

Incident Status: Resolved

Description: This is to update you that our eSIM Platform vendor has resolved the issue.

We are closely monitoring the services and will provide updates if necessary.

Regards,
Telna Support
Posted Dec 10, 2025 - 20:34 UTC

Update

Hello,

This is to update you regarding the following incident:

Incident Status: Monitoring

Description: This is to update you that our eSIM Platform vendor has resolved the issue.

We are closely monitoring the services and will provide updates if necessary.

Regards,
Telna Support
Posted Dec 10, 2025 - 20:33 UTC

Identified

Hello,

This is to update you regarding the following incident:

Incident Status: Identified (Fix in Progress)

Description:
The service degradation has been confirmed with the eSIM Platform vendor.
The vendor’s engineering team has narrowed the investigation, identified the root cause, and is actively working on a resolution.

Service Impact:
Devices may encounter difficulties activating eSIM.

We are continuing to monitor performance and will share the ETA as soon as it is provided, along with further updates on progress.

Regards,
Telna Support
Posted Dec 10, 2025 - 16:51 UTC

Investigating

Hello,

This is to update you regarding the following incident:

Incident Status: Investigating

Description:
We are observing a service degradation with the eSIM Platform vendor.

Service Impact:
Devices may encounter issues activating eSIM.
The vendor's engineering team is working to resolve it as soon as possible.

We are constantly checking with them and monitoring the performance.
We will keep you updated.

Regards,
Telna Support
Posted Dec 10, 2025 - 14:06 UTC
This incident affected: Connect Platform (Connect for Wholesale, Connect API).