Cronus Platform Performance Degradation
Incident Report for Telna Status
Resolved
Hello,

This is to update you regarding the following incident:

Incident Status: Resolved

Description: We would like to update you that our teams completed the full recovery of services.

We are monitoring the services closely and will update you if needed.

Should you have any questions feel free to contact us.

Regards,
Telna Support
Posted May 03, 2024 - 04:57 UTC
Investigating
We are experiencing performance degradation on Cronus and the team is investigating the issue.
Posted May 02, 2024 - 22:01 UTC
This incident affected: Cronus Platform (Cronus for Wholesale, Cronus Frontend, Cronus API).