eSIM Platform Vendor Service Degradation
Incident Report for Telna Status
Resolved
Hello,

This is to update you regarding the following incident:

Incident Status: Resolved

Description: This is to update you that the issue has been resolved.

We are closely monitoring the service and will provide updates if necessary.
Posted Jan 15, 2025 - 17:29 UTC
Investigating
Hello,

This is to update you regarding the following incident:

Incident Status: Investigating

Description: We are observing a service degradation with the eSIM Platform vendor.

Service Impact: Devices may encounter issues activating eSIM.

The vendor's engineering team is working to resolve it as soon as possible.

We are constantly checking with them and monitoring the performance. We will keep you updated.

Regards,
Telna Support
Posted Jan 15, 2025 - 16:40 UTC
This incident affected: Cronus Platform (Cronus for Wholesale).