Service Degradation with AWS Impacting IMSI 7

Incident Report for Telna Status

Resolved

Hello,

This is to update you regarding the following incident:

Incident Status: Resolved

Description: This is to update you that the issue has been resolved.

We are closely monitoring the services and will provide updates if necessary.

Regards,
Telna Support
Posted Oct 20, 2025 - 21:14 UTC

Investigating

Hello,

This is to update you regarding the following incident:

Incident Status: Investigating

Description: Amazon Web Services (AWS) is currently experiencing a global network service degradation, resulting in connectivity issues impacting IMSI 7.

Service Impact: Devices may experience difficulties establishing new data sessions. Existing sessions remain unaffected.

AWS is actively working to resolve the issue as soon as possible. Our team is closely monitoring the situation and working on rerouting traffic. We will continue to provide updates as they become available.

Affected Countries/Region: Europe

Regards,
Telna Support
Posted Oct 20, 2025 - 16:15 UTC
This incident affected: IMSI 7 (Data Services EU).