Cronus Email Service Degradation
Incident Report for Telna Status
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 13:47 UTC
Investigating
Hello,

This is to update you regarding this incident has been resolved.

Regards,
Telna Support
Posted Mar 21, 2024 - 20:12 UTC
Identified
Hello,

This is to update you regarding degradation with emails sent from Cronus platform

Incident Status: New

We are curently checking the issue and will update you once new information becomes available.

Service Impact: Emails might be not send from the platform.
Posted Mar 20, 2024 - 17:48 UTC
This incident affected: Cronus Platform (Cronus for Wholesale).