Cronus SIMs page performance degradation.
Incident Report for Telna Status
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 16:30 UTC
Update
We are continuing to investigate this issue.
Posted Apr 10, 2024 - 16:29 UTC
Investigating
We are experiencing performance degradation on the SIMs loading page.
We are working on the resolution of this incident.

If you encounter timeouts whilst listing the SIM's page, please follow the below steps:

1. Enter the ICCID in the search bar and click the search button to the right of the search box. (Single SIM Search).
2. Or select from the dropdown options to the left of the search box and search by Company or Inventory.
Posted Apr 09, 2024 - 22:30 UTC
This incident affected: Cronus Platform (Cronus for Wholesale, Cronus Frontend).